Delayed starts to scheduled mailings
Incident Report for FeedBlitz
Resolved
Last few delayed mailings are wrapping up now
Posted May 08, 2024 - 01:20 EDT
Monitoring
Scheduled mailings are now going out, and mailings scheduled from midnight US eastern are running as expected. We apologize for any inconvenience if your mailing's start was delayed. We are tracking the mailings to ensure that they all complete.
Posted May 08, 2024 - 00:29 EDT
Update
We are continuing to work on a fix for this issue.
Posted May 07, 2024 - 23:48 EDT
Update
We are continuing to work on a fix for this issue.
Posted May 07, 2024 - 22:37 EDT
Identified
Mailings are not in fact delayed! However reporting of subscribers mailed is incorrect. We are working on a solution-
Posted May 07, 2024 - 22:30 EDT
Investigating
We are currently investigating this issue.
Posted May 07, 2024 - 22:18 EDT
This incident affected: Email Marketing.